Excel Offset Kaydır Fonksiyonu

| 02 Nisan 2016 |




Excel OffSET Kaydır Fonksiyonu;

Kaydır daha çok Excel de statik değil de dinamik tanımlamalara ihtiyacımız olduğu durumlarda kullanılan bir fonksiyondur. Aslında belli bir referansa göre koordinatlara vererek gitme ve burdan belli bir alanı başvuru alanı seçmek için kullanabiliriz. (Offset yada Kaydır)

KAYDIR(başv; satırlar; sütunlar; [yükseklik]; [genişlik]) 

Satırlar ve sütünlar da+ pozitif , – negatif değer kullanmak ilerleme yönünü gösterir.

Yükseklik ve genişlik yazılmaz ise Excel için bu değer 1 dir.

Bu fonksiyonu TOPLA, BAG_DEĞER_SAY gibi fonksiyonların içinde yada dışında kullanabiliriz.

Örnek Kullanımlar;

=TOPLA(KAYDIR(D3:F5,3,-2, 3, 3))

=KAYDIR($A$2;;;BAĞ_DEĞ_SAY($A:$A);)

=KAYDIR($A$2;BAĞ_DEĞ_SAY($A:$A)-$C$2;;$C$2;)

Önemli Olan Aşağıdaki Yapıyı Anlamaktan Geçiyor;

B2 referans değerimden +2 ve +3 hareketle E4 yeni hedefime ulaşıyorum. Eğer bir başvuru aralığı yapacaksam yükseklik ve genişlik belirliyorum. Hepsi budur 🙂  ( referansa göre -2 veya -3 de gidilebilird ama ama B2 bu mumkun olmayacaktır)KAYDIR_OFFSET_EXCEL



=KAYDIR(B2;2;3;4;5) Excelde hata verirken aslında Ad Yöneticisinde Anlam Kazanacaktır. Buna “we” diye bir ad verdim.

Burada we olarak adlandırılan ad aslında Topla (we) yada Topla (E4:I7) ile aynı anlama gelir.

KAYDIR_OFFSET_EXCE_01L.jpg



Kategori: Yazılım

Bora M. Deniz ()

Teknoloji, internet, ve bilişim gibi konularda paylaşımlarım ve yazılarımla 2011 den beri teknorapor.com dayım. Sosyal medya da yararlı bulduğunuz yazılarımı paylaşmanız dileklerimle... The author shares and writings IT, internet and technology news blog offering

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir