excel düşeyara vlookup formulü

| 20 Temmuz 2011 | 1 Yorum






EXCEL VLOOKUP   yada DÜŞEYARA

foksiyonu bana göre çok önemli bir işleve sahiptir. Excel kullananlara çok büyük kolaylık sağlayacaktır. Hemen anlatmaya başlayalım.

  • Excelde   Kitap1 adında bir dosya oluşturalım.
  • İlk sayfamızda OgrenciKartları olsun. Bu alanda Ekrandaki gibi bir bilgi olduğunu varsayalım.
  • İkinci sayfamız ise notlar sayfası olsun biz notlar sayfasına OgrenciNo yu yazdığımızda otomatik olarak Ad ve Soyad bilgisini gelmesini istediğimizi varsayalım.
  • Öncelikle A,B,C Sütunlarını mouse ile seçelim.
  • Daha sonra Ribbon   sekmemizde yer alan Formullerde > Ad tanımla düğmesini tıklatalım.
  • Bu alanın adına otomatik olarak A1 hücresindeki isim geldi siz istediğiniz adı verip Tamam diyorsunuz.
  • Bu tabloda anahtar sütunun daima en solda olması gerekir. Yani getireğimiz alanlar anahtarın hep sağında yer almalı.
  • Ekran görüntüsündeki gibi. Biz şu anda bu Kitap1 excel dosyası   içersinde OgrenciKartları sayfasındaki ABC sütünlarını kapsayan aralığa OgrenciNo adını vermiş olduk. Zaten ekranda =OgrenciKartlari!$A:$C şeklinde bu alanı görüyorsunuz.

Simdi Notlar sayfasını açalım,

  • Bu sayfada F2 hücresine =DÜŞEYARA($A2;OgrenciNo;2;0) yazıyoruz. Burada A2 ye yani 1220 nolu Ögrenciyi, daha önceden oluşturduğum OgrenciNo aralığından bak, bana 2 ci sütunda yazan değeri, 0 doğrulukla yani birebir getir diyorum.
  • Bu formulde 4 değişken var Birincisi neyi arıyorum “;” ikincisi nerde arıyorum “;” ücüncüsü aradığımı bulduğumda hangi sütunu getireyim“;” dördüncüsü birebir getir (0,yanlış) yakın değeri (1,doğru) getir.

Burada Aralık tanımı (OgrenciNo idi ) yapmaya gerek duymazsam bunu =DÜŞEYARA($A2;OgrenciKartlari!$A:$C;3;0) olarakta yazabilirim ve OgrenciSoyadı da G2 hücresine gelmiş oldu.Burada dikkat ederseniz soyadı getirmek için formulde ilgili yere 3 yazdım. İlk ekran görüntüsünde tanımladığın alanın 3. sutunu olduğu için değil. Aslında Refransım 1 dir ondan sonra sağa doğru sayıyorum ve soyad 3 de. Tablo farklıda olabilirdi o yüzden hep refaransa göre bu değeri belirlemeliyim.

  Kısaca;

ingilizce versiyonda:   =VLOOKUP($A2;OgrenciNo;2;0) veya  =VLOOKUP($A2;OgrenciNo;2;FALSE)

türkçe versiyonda       :   =DÜŞEYARA($A2;OgrenciNo;2;0) veya =DÜŞEYARA($A2;OgrenciNo;2;YANLIŞ)

Yatayara hlookup için bu sayfamı ziyaret edebilirsiniz.



Kategori: Yazılım

Bora M. Deniz ()

Teknoloji, internet, ve bilişim gibi konularda paylaşımlarım ve yazılarımla 2011 den beri teknorapor.com dayım. Sosyal medya da yararlı bulduğunuz yazılarımı paylaşmanız dileklerimle... The author shares and writings IT, internet and technology news blog offering

Yorum (1)

Trackback URL | Yorum RSS

  1. editor diyor ki:

    Faydalı olmasını umarım.

    Bu anlatım size karışık mı geldi ? Yada faydalı oldu mu? yorumlarda belirtirseniz yazıyı one göre tekrar düzenlemek isterim.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir